summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2024-01-26 21:58:30 +0100
committerHelmut Grohne <helmut@subdivi.de>2024-01-26 21:58:30 +0100
commit9f7a434600f43c0e9ec45ca8569ca3c2fe3c269b (patch)
treeac98a2891280dbd9a7b69a857b751a39291ba660 /pyproject.toml
parent2ae049ad514340cc8a286fb90945be827afbac0d (diff)
downloadpython-linuxnamespaces-9f7a434600f43c0e9ec45ca8569ca3c2fe3c269b.tar.gz
add some metadata to a first pyproject.toml
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e81eabd
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,23 @@
+[project]
+name = "linuxnamespaces"
+description = "typed syscall wrappers and plumbing for working with Linux namespaces"
+authors = [{name = "Helmut Grohne", email = "helmut@subdivi.de"}]
+classifiers = [
+ "Development Status :: 3 - Alpha",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: POSIX :: Linux",
+ "Typing :: Typed",
+ "Programming Language :: Python :: 3",
+]
+
+[project.optional-dependencies]
+test = ["pytest"]
+
+[tool.black]
+line-length = 79
+
+[tool.mypy]
+strict = true
+
+[tool.pylint]
+max-line-length=79