summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2024-05-09 12:06:28 +0200
committerHelmut Grohne <helmut@subdivi.de>2024-05-09 12:06:28 +0200
commitaea61a6192949d36adff0b369a4fd2c03502441b (patch)
treee15c82a5d77f4a0943b09db4e85440886c17c4cb /pyproject.toml
parentcd0ada6b19b03bda74fcb81316aa104e0d1bbac6 (diff)
downloadpython-linuxnamespaces-aea61a6192949d36adff0b369a4fd2c03502441b.tar.gz
add linuxnamespaces.tarutils
Move the generic tar utilities from the chroottar.py example into a linuxnamespaces module as dealing with tar archives is a fairly common thing when dealing with namespaces.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 481593a..04d6a5f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -15,8 +15,9 @@ requires-python = ">=3.9"
# linuxnamespaces.systemd needs jeepney or dbussy, not both.
jeepney = ["jeepney"]
dbussy = ["dbussy"]
+# linuxnamespaces.tarutils.ZstdTarFile
+zstandard = ["zstandard"]
test = ["pytest", "pytest-forked", "pytest-subtests"]
-examples = ["zstandard"]
[tool.black]
line-length = 79