summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2022-12-06 20:53:03 +0100
committerHelmut Grohne <helmut@subdivi.de>2022-12-06 20:53:03 +0100
commit27609514f0a95b5bb7b6d6ef8c4029c9cf9e636d (patch)
tree3ca9df5dbb005a965664985458df2ed60480470b /pyproject.toml
parent19c246e988335de7c2644544b269b021815cc051 (diff)
downloadwsgitools-27609514f0a95b5bb7b6d6ef8c4029c9cf9e636d.tar.gz
add a pyproject.toml
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..18abc10
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,37 @@
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "wsgitools"
+description = "a set of tools working with WSGI (see PEP 333)"
+readme = "README"
+license = {file = "LICENSE"}
+authors = [{name="Helmut Grohne", email="helmut@subdivi.de"}]
+maintainers = [{name="Helmut Grohne", email="helmut@subdivi.de"}]
+keywords = ["wsgi", "pep333", "scgi"]
+urls=[{homepage="http://subdivi.de/~helmut/wsgitools/"}]
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: No Input/Output (Daemon)",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: GNU General Public License (GPL)",
+ "Natural Language :: English",
+ "Programming Language :: Python",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Internet :: WWW/HTTP :: WSGI",
+ "Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
+ "Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware",
+ "Topic :: Internet :: WWW/HTTP :: WSGI :: Server",
+]
+requires-python = ">=2.7"
+version="0.3.1"
+
+[tool.pylint]
+max-line-length = 80
+disable = [
+ "C0209", # Py2.x support
+ "R0205", # Py2.x support
+ "W0707", # Py2.x support
+]