summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2007-05-08 20:18:42 +0200
committerHelmut Grohne <helmut@subdivi.de>2007-05-08 20:18:42 +0200
commitc4a3e7e0947da2896be9b54876db3bd67444e7a4 (patch)
tree9d7d89ff18e850e2bec7cdfe4ca5dff008c4be64 /setup.py
parent8052cfbc7ceab30a59ea89bec5cc583b0ead116f (diff)
downloadwsgitools-c4a3e7e0947da2896be9b54876db3bd67444e7a4.tar.gz
added setup.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..39b06bb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,28 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(name="wsgitools",
+ version="0.1",
+ description="a set of tools working with WSGI (see PEP 333)",
+ author="Helmut Grohne",
+ author_email="helmut@subdivi.de",
+ url="http://subdivi.de/~helmut/wsgitools/",
+ platforms = ["any"],
+ license="GPL",
+ keywords=["wsgi", "pep333", "scgi"],
+ classifiers=[
+ "Development Status :: 3 - Alpha",
+ "Environment :: No Input/Output (Daemon)",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: GNU General Public License (GPL)",
+ "Natural Language :: English",
+ "Programming Language :: Python",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Internet :: WWW/HTTP :: WSGI",
+ "Topic :: Internet :: WWW/HTTP :: WSGI :: Application",
+ "Topic :: Internet :: WWW/HTTP :: WSGI :: Middleware",
+ "Topic :: Internet :: WWW/HTTP :: WSGI :: Server"
+ ],
+ packages=["wsgitools", "wsgitools.scgi"])